本文主要介紹在使用SMC遷移時,遷移任務出錯提示“S2_* 磁盤分區文件數據同步出錯”的問題描述、問題原因及其解決方案。
問題描述
在SMC遷移時,遷移任務出錯提示“S2_* 磁盤分區文件數據同步出錯”。其中S2_*可能的錯誤碼如下:
S2_R255
S2_R11
S2_R1
S2_R12
S2_R70
問題原因
源系統SMC客戶端進行磁盤分區文件級別的數據同步時出錯,可能原因有:
S2_R255:源系統到目標實例的IP:8703端口網絡連接不通。
S2_R11:遷移任務設置的目標磁盤分區大小小于源系統磁盤分區實際數據量,目標分區空間不足導致。
S2_R1:源系統安裝的Rsync版本為3.0.6以下或者不支持ACLs能力。
S2_R12:源系統到目標實例的IP:8703端口網絡中斷。
S2_R70:源系統磁盤分區文件數據同步卡住,導致遷移任務超時。
解決方案
不同的錯誤碼對應的解決方案如下:
S2_R255
檢查源系統到目標實例的IP:8703端口網絡訪問是否正常。
檢查目標實例的安全組端口是否已放開入方向的8703端口,或者是否有其他安全組規則沖突限制。
說明默認情況下SMC任務會自動給目標實例關聯一個臨時安全組,來放開目標實例的入方向8703端口。
使用
telnet
命令測試到目標實例8703端口是否連通,如果不通,需要排查本地網絡配置或中間網絡設備,如防火墻或代理出方向是否有IP端口訪問限制。
S2_R11
檢查遷移任務目標磁盤分區大小是否小于源系統磁盤分區實際數據量,如果小于,則需要重建遷移任務并設置合適的磁盤分區大小后再試。
S2_R1
使用
rsync --version
檢查源系統rsync版本。建議rsync為3.0.6及以上版本,最新版本是3.1.3,同時檢查是否支持ACLs能力,如果沒有ACLs則表示不支持,此時需要重裝rsync后再試。
S2_R12
檢查源系統到目標實例的IP:8703端口網絡是否正常穩定,遷移過程中不要中斷網絡,待網絡正常后再試。
S2_R70
檢查源系統到目標實例的IP:8703端口網絡是否正常穩定,源系統帶寬速度是否足夠,防止因網絡帶寬過小導致的傳輸進度過慢而超時。
檢查源系統磁盤分區是否存在以下情況并處理:
動態變化的大文件,如數據庫數據文件或日志文件。
可以考慮在合適的時間點暫停相關數據業務服務,確保遷移的過程中大文件不再動態變化后再試。
使用過濾配置排除相關目錄后再試,具體操作,請參見如何過濾、排除不需要遷移的文件或目錄?。對于未遷移的文件或目錄,后續可考慮用其他方案遷移。
大量小文件,如分布式文件系統海量數據、文件服務器等。
使用過濾配置排除相關目錄后再試,具體操作,請參見如何過濾、排除不需要遷移的文件或目錄?。對于未遷移的文件或目錄,后續可考慮用其他方案遷移。
問題排查解決后,運行SMC客戶端再試。具體操作,請參見運行SMC客戶端。